> ## Documentation Index
> Fetch the complete documentation index at: https://docs.kinetica.com/llms.txt
> Use this file to discover all available pages before exploring further.

# /insert/records/frompayload

```
URL: http://<db.host>:<db.port>/insert/records/frompayload
```

Reads from the given text-based or binary payload and inserts the data into a
new or existing table.  The table will be created if it doesn't already exist.

Returns once all records are processed.

## Input Parameter Description

<ParamField body="table_name" type="string">
  Name of the table into which the data will be inserted, in \[schema\_name.]table\_name format, using standard [name resolution rules](../../concepts/tables/#table-name-resolution). If the table does not exist, the table will be created using either an existing *type\_id* or the type inferred from the payload, and the new table name will have to meet standard [table naming criteria](../../concepts/tables/#table-naming-criteria).
</ParamField>

<ParamField body="data_text" type="string">
  Records formatted as delimited text.
</ParamField>

<ParamField body="data_bytes" type="bytes">
  Records formatted as binary data.
</ParamField>

<ParamField body="modify_columns" type="map of string to maps of string to strings">
  Not implemented yet.

  The default value is an empty map ( \{} ).
</ParamField>

<ParamField body="create_table_options" type="map of string to strings">
  Options used when creating the target table. Includes type to use. The other options match those in [/create/table](/content/api/rest/create_table_rest).

  The default value is an empty map ( \{} ).

  <Expandable title="create_table_options">
    <ParamField body="chunk_column_max_memory">
      Indicates the target maximum data size for each column in a chunk to be used for this table.
    </ParamField>

    <ParamField body="chunk_max_memory">
      Indicates the target maximum data size for all columns in a chunk to be used for this table.
    </ParamField>

    <ParamField body="chunk_size">
      Indicates the number of records per chunk to be used for this table.
    </ParamField>

    <ParamField body="compression_codec">
      The default [compression codec](../../concepts/column_compression/) for this table's columns.
    </ParamField>

    <ParamField body="foreign_keys">
      Semicolon-separated list of [foreign keys](../../concepts/tables/#foreign-keys), of the format '(source\_column\_name \[, ...]) references target\_table\_name(primary\_key\_column\_name \[, ...]) \[as foreign\_key\_name]'.
    </ParamField>

    <ParamField body="foreign_shard_key">
      Foreign shard key of the format 'source\_column references shard\_by\_column from target\_table(primary\_key\_column)'.
    </ParamField>

    <ParamField body="is_automatic_partition">
      If *true*, a new partition will be created for values which don't fall into an existing partition.  Currently only supported for [list partitions](../../concepts/tables/#partitioning-by-list).

      The default value is `false`.

      The supported values are:

      * true
      * false
    </ParamField>

    <ParamField body="is_replicated">
      Affects the [distribution scheme](../../concepts/tables/#distribution) for the table's data.  If *true* and the given type has no explicit [shard key](../../concepts/tables/#shard-key) defined, the table will be [replicated](../../concepts/tables/#replication). If *false*, the table will be [sharded](../../concepts/tables/#sharding) according to the shard key specified in the given *type\_id*, or [randomly sharded](../../concepts/tables/#random-sharding), if no shard key is specified.  Note that a type containing a shard key cannot be used to create a replicated table.

      The default value is `false`.

      The supported values are:

      * true
      * false
    </ParamField>

    <ParamField body="is_result_table">
      Indicates whether the table is a [memory-only table](../../concepts/tables_memory_only/). A result table cannot contain columns with text\_search [data-handling](../../concepts/types/#data-handling), and it will not be retained if the server is restarted.

      The default value is `false`.

      The supported values are:

      * true
      * false
    </ParamField>

    <ParamField body="no_error_if_exists">
      If *true*, prevents an error from occurring if the table already exists and is of the given type.  If a table with the same ID but a different type exists, it is still an error.

      The default value is `false`.

      The supported values are:

      * true
      * false
    </ParamField>

    <ParamField body="partition_definitions">
      Comma-separated list of partition definitions, whose format depends on the choice of *partition\_type*.  See [range partitioning](../../concepts/tables/#partitioning-by-range), [interval partitioning](../../concepts/tables/#partitioning-by-interval), [list partitioning](../../concepts/tables/#partitioning-by-list), [hash partitioning](../../concepts/tables/#partitioning-by-hash), or [series partitioning](../../concepts/tables/#partitioning-by-series) for example formats.
    </ParamField>

    <ParamField body="partition_keys">
      Comma-separated list of partition keys, which are the columns or column expressions by which records will be assigned to partitions defined by *partition\_definitions*.
    </ParamField>

    <ParamField body="partition_type">
      [Partitioning](../../concepts/tables/#partitioning) scheme to use.

      * **RANGE**: Use [range partitioning](../../concepts/tables/#partitioning-by-range).
      * **INTERVAL**: Use [interval partitioning](../../concepts/tables/#partitioning-by-interval).
      * **LIST**: Use [list partitioning](../../concepts/tables/#partitioning-by-list).
      * **HASH**: Use [hash partitioning](../../concepts/tables/#partitioning-by-hash).
      * **SERIES**: Use [series partitioning](../../concepts/tables/#partitioning-by-series).
    </ParamField>

    <ParamField body="strategy_definition">
      The [tier strategy](../../rm/concepts/#tier-strategies) for the table and its columns.
    </ParamField>

    <ParamField body="ttl">
      Sets the [TTL](../../concepts/ttl/) of the table specified in input parameter *table\_name*.
    </ParamField>

    <ParamField body="type_id">
      ID of a currently registered [type](../../concepts/types/).

      The default value is ''.
    </ParamField>
  </Expandable>
</ParamField>

<ParamField body="options" type="map of string to strings">
  Optional parameters.

  The default value is an empty map ( \{} ).

  <Expandable title="options">
    <ParamField body="avro_schema">
      String representing the Avro schema, for data that includes only records (i.e. does not embed its own schema).
    </ParamField>

    <ParamField body="avro_schema_no_inference">
      Create table solely from the Avro schema definition, when *avro\_schema* exists; do not infer from data.

      The supported values are:

      * true
      * false
    </ParamField>

    <ParamField body="bad_record_table_limit">
      A positive integer indicating the maximum number of records that can be written to the bad-record-table. Default value is 10000.
    </ParamField>

    <ParamField body="bad_record_table_limit_per_input">
      For subscriptions: A positive integer indicating the maximum number of records that can be written to the bad-record-table per file/payload. Default value will be 'bad\_record\_table\_limit' and total size of the table per rank is limited to 'bad\_record\_table\_limit'.
    </ParamField>

    <ParamField body="bad_record_table_name">
      Name of a table to which records that were rejected are written.  The bad-record-table has the following columns: line\_number (long), line\_rejected (string), error\_message (string).
    </ParamField>

    <ParamField body="batch_size">
      Internal tuning parameter--number of records per batch when inserting data.
    </ParamField>

    <ParamField body="column_formats">
      For each target column specified, applies the column-property-bound format to the source data loaded into that column.  Each column format will contain a mapping of one or more of its column properties to an appropriate format for each property.  Currently supported column properties include date, time, and datetime. The parameter value must be formatted as a JSON string of maps of column names to maps of column properties to their corresponding column formats, e.g., '\{ "order\_date" : \{ "date" : "%Y.%m.%d" }, "order\_time" : \{ "time" : "%H:%M:%S" } }'.

      See *default\_column\_formats* for valid format syntax.
    </ParamField>

    <ParamField body="columns_to_load">
      Specifies a comma-delimited list of source-data columns that supply the target table's columns. If more than one file is being loaded, this list applies to all files.

      Mutually exclusive with *columns\_to\_skip*.

      This list is a positional mapping onto the target table rather than a filter: the i-th entry identifies the source column that feeds the i-th column of the target table.

      Entries may be column numbers, column names, or empty.

      Column numbers are 1-based, specified discretely or as a range. For example, '5,7,,1..3' inserts the fifth source column into the first target column, the seventh into the second, null into the third, and the first through third into the fourth through sixth. A range may descend ('3..1') to reverse that group's order.  Zero is not a valid column number. Numbers are supported only for delimited-text and Avro sources.

      Column names are strings, matching the source-data field names -- either the file's header names or the names supplied by *name\_columns\_from\_file*. Requires that the source data have column names. Names are matched case-sensitively, and a name not present in the source will fail.

      An empty entry, acting as a placeholder meaning that no source column feeds the corresponding target column.

      Numbers and names cannot be mixed: a single non-numeric entry causes the entire list to be interpreted as names.

      If the target table does not exist, it is created with these columns in this order, and the list may name any subset of the source columns.

      If the target table already exists, the number of entries must equal the target table's column count. Use empty entries to pad the list to the target's width. Because the mapping is positional, this option can also reorder source columns into the target's column order -- for example 'C, B, A' for a target table whose columns are C, B, A.

      Note: specifying *columns\_to\_load* disables server-side population of target columns that no source column feeds. Such columns receive NULL instead of their default value, 'init\_with\_now', or 'init\_with\_uuid' value; if the column is non-nullable, the record is rejected. To have unfed target columns take their defaults, omit *columns\_to\_load* and rely on name-based matching, optionally with *columns\_to\_skip*.
    </ParamField>

    <ParamField body="columns_to_skip">
      Specifies a comma-delimited list of source-data columns to exclude from the load. If more than one file is being loaded, this list applies to all files.

      Mutually exclusive with *columns\_to\_load*.

      Entries may be column names matching the source-data field names (the file's header names, or the names supplied by *name\_columns\_from\_file*, matched case-sensitively), or 1-based column numbers. Numbers are supported only for delimited-text sources. Name-based entries require the source data to have column names.

      Unlike *columns\_to\_load*, this option does not change how the remaining source columns are matched to the target table. Matching remains by name and is case-insensitive, so the order and number of source columns need not correspond to the target table's columns.

      Excluding a source column that corresponds to a target table column causes that target column to be populated from its default value, 'init\_with\_\*' property, or null.  This makes *columns\_to\_skip* the means of preferring a target column's default over a value present in the source data.

      Source columns that don't correspond to any target table column need not be listed; they are ignored.

      If the target table does not exist, the non-excluded source columns define the new table's columns, in source-data order.

      If the source data has no column names (no header row and no *name\_columns\_from\_file*) and this option is given as numbers, the remaining source columns are matched to target columns by position; the source column count must then equal the target table's column count plus the number of columns skipped.
    </ParamField>

    <ParamField body="compression_type">
      Payload compression type.

      The default value is `auto`.

      * **none**: Uncompressed.
      * **auto**: Default. Auto detect compression type.
      * **gzip**: gzip file compression.
      * **bzip2**: bzip2 file compression.
    </ParamField>

    <ParamField body="default_column_formats">
      Specifies the default format to be applied to source data loaded into columns with the corresponding column property.  Currently supported column properties include date, time, and datetime.  This default column-property-bound format can be overridden by specifying a column property and format for a given target column in *column\_formats*. For each specified annotation, the format will apply to all columns with that annotation unless a custom *column\_formats* for that annotation is specified.

      The parameter value must be formatted as a JSON string that is a map of column properties to their respective column formats, e.g., '\{ "date" : "%Y.%m.%d", "time" : "%H:%M:%S" }'.  Column formats are specified as a string of control characters and plain text. The supported control characters are 'Y', 'm', 'd', 'H', 'M', 'S', and 's', which follow the Linux 'strptime()' specification, as well as 's', which specifies seconds and fractional seconds (though the fractional component will be truncated past milliseconds).

      Formats for the 'date' annotation must include the 'Y', 'm', and 'd' control characters. Formats for the 'time' annotation must include the 'H', 'M', and either 'S' or 's' (but not both) control characters. Formats for the 'datetime' annotation meet both the 'date' and 'time' control character requirements. For example, '\{"datetime" : "%m/%d/%Y %H:%M:%S" }' would be used to interpret text as "05/04/2000 12:12:11"
    </ParamField>

    <ParamField body="enable_inplace_updates">
      Applies only when upserting (when update\_on\_existing\_pk is true). If set to true (the default), an existing record matched by primary key is modified in place. If set to false, the matched record is updated by deleting it and inserting a replacement (delete and insert), which prevents the change from being reflected in dependent materialized views until they are refreshed.

      The default value is `true`.

      The supported values are:

      * true
      * false
    </ParamField>

    <ParamField body="error_handling">
      Specifies how errors should be handled upon insertion.

      The default value is `abort`.

      * **permissive**: Records with missing columns are populated with nulls if possible; otherwise, the malformed records are skipped.
      * **skip**: Malformed records are skipped.
      * **ignore\_bad\_records**: Deprecated. Alias for *skip*.
      * **abort**: Stops current insertion and aborts entire operation when an error is encountered.  Primary key collisions are considered abortable errors in this mode.
    </ParamField>

    <ParamField body="file_type">
      Specifies the type of the file(s) whose records will be inserted.

      The default value is `delimited_text`.

      * **avro**: Avro file format.
      * **delimited\_text**: Delimited text file format; e.g., CSV, TSV, PSV, etc.
      * **gdb**: Esri/GDB file format.
      * **json**: JSON file format.
      * **parquet**: Apache Parquet file format.
      * **shapefile**: ShapeFile file format.
    </ParamField>

    <ParamField body="flatten_columns">
      Specifies how to handle nested columns.

      The default value is `false`.

      * **true**: Break up nested columns to multiple columns.
      * **false**: Treat nested columns as JSON columns instead of flattening.
    </ParamField>

    <ParamField body="gdal_configuration_options">
      Comma separated list of gdal conf options, for the specific requests: key=value.

      The default value is ''.
    </ParamField>

    <ParamField body="ignore_existing_pk">
      Specifies the record collision error-suppression policy for inserting into a table with a [primary key](../../concepts/tables/#primary-keys), only used when not in upsert mode (upsert mode is disabled when *update\_on\_existing\_pk* is *false*).  If set to *true*, any record being inserted that is rejected for having primary key values that match those of an existing table record will be ignored with no error generated.  If *false*, the rejection of any record for having primary key values matching an existing record will result in an error being reported, as determined by *error\_handling*.  If the specified table does not have a primary key or if upsert mode is in effect (*update\_on\_existing\_pk* is *true*), then this option has no effect.

      The default value is `false`.

      * **true**: Ignore new records whose primary key values collide with those of existing records.
      * **false**: Treat as errors any new records whose primary key values collide with those of existing records.
    </ParamField>

    <ParamField body="ingestion_mode">
      Whether to do a full load, dry run, or perform a type inference on the source data.

      The default value is `full`.

      * **full**: Run a type inference on the source data (if needed) and ingest.
      * **dry\_run**: Does not load data, but walks through the source data and determines the number of valid records, taking into account the current mode of *error\_handling*.
      * **type\_inference\_only**: Infer the type of the source data and return, without ingesting any data.  The inferred type is returned in the response.
    </ParamField>

    <ParamField body="layer">
      Geo files layer(s) name(s): comma separated.

      The default value is ''.
    </ParamField>

    <ParamField body="loading_mode">
      Scheme for distributing the extraction and loading of data from the source data file(s). This option applies only when loading files that are local to the database.

      The default value is `head`.

      * **head**: The head node loads all data. All files must be available to the head node.
      * **distributed\_shared**: The head node coordinates loading data by worker processes across all nodes from shared files available to all workers. NOTE: Instead of existing on a shared source, the files can be duplicated on a source local to each host to improve performance, though the files must appear as the same data set from the perspective of all hosts performing the load.
      * **distributed\_local**: A single worker process on each node loads all files that are available to it. This option works best when each worker loads files from its own file system, to maximize performance. In order to avoid data duplication, either each worker performing the load needs to have visibility to a set of files unique to it (no file is visible to more than one node) or the target table needs to have a primary key (which will allow the worker to automatically deduplicate data). NOTE: If the target table doesn't exist, the table structure will be determined by the head node. If the head node has no files local to it, it will be unable to determine the structure and the request will fail. If the head node is configured to have no worker processes, no data strictly accessible to the head node will be loaded.
    </ParamField>

    <ParamField body="local_time_offset">
      For Avro local timestamp columns.
    </ParamField>

    <ParamField body="max_consecutive_invalid_schema_failure">
      Max records to skip due to schema related errors, before failing.
    </ParamField>

    <ParamField body="max_records_to_load">
      Limit the number of records to load in this request: If this number is larger than a batch\_size, then the number of records loaded will be limited to the next whole number of batch\_size (per working thread).

      The default value is ''.
    </ParamField>

    <ParamField body="name_columns_from_file">
      Specifies a comma-delimited list of column names to be used as the source-data column names. Supported for delimited-text sources only.

      The i-th name in this list applies to the i-th column in the file. If the file has a header row (i.e., *text\_has\_header* is *true*), these names override the file's header names. If the file has no header row, these names become the source-data column names.

      Naming the source columns enables name-based matching against the target table's columns, and permits name-based *columns\_to\_load* / *columns\_to\_skip*, which otherwise require a header row.

      Note: for a source with no header row, supplying this option changes how source columns are matched to target columns -- from positional matching to matching by name. Target columns with no matching source column are then populated from their defaults or null rather than being filled positionally.

      The list is not validated against the file's actual column count. If it is shorter, the trailing source columns are left unnamed.
    </ParamField>

    <ParamField body="num_tasks_per_rank">
      Number of tasks for reading file per rank. Default will be [external\_file\_reader\_num\_tasks](../../config/#config-main-external-files).
    </ParamField>

    <ParamField body="pk_conflict_predicate_higher">
      The record with higher value for the column resolves the primary-key insert conflict.

      The default value is ''.
    </ParamField>

    <ParamField body="pk_conflict_predicate_lower">
      The record with lower value for the column resolves the primary-key insert conflict.

      The default value is ''.
    </ParamField>

    <ParamField body="poll_interval">
      If *true*, the number of seconds between attempts to load external files into the table.  If zero, polling will be continuous as long as data is found.  If no data is found, the interval will steadily increase to a maximum of 60 seconds.
    </ParamField>

    <ParamField body="primary_keys">
      Comma separated list of column names, to set as primary keys, when not specified in the type.

      The default value is ''.
    </ParamField>

    <ParamField body="schema_registry_connection_retries">
      Confluent Schema registry connection timeout (in secs).
    </ParamField>

    <ParamField body="schema_registry_connection_timeout">
      Confluent Schema registry connection timeout (in secs).
    </ParamField>

    <ParamField body="schema_registry_max_consecutive_connection_failures">
      Max records to skip due to SR connection failures, before failing.
    </ParamField>

    <ParamField body="schema_registry_schema_name">
      Name of the Avro schema in the schema registry to use when reading Avro records.
    </ParamField>

    <ParamField body="shard_keys">
      Comma separated list of column names, to set as shard keys, when not specified in the type.

      The default value is ''.
    </ParamField>

    <ParamField body="skip_lines">
      Skip a number of lines from the beginning of the file.
    </ParamField>

    <ParamField body="subscribe">
      Continuously poll the data source to check for new data and load it into the table.

      The default value is `false`.

      The supported values are:

      * true
      * false
    </ParamField>

    <ParamField body="table_insert_mode">
      When inserting records from multiple files: if *table\_per\_file*, then insert from each file into a new table. Currently supported only for shapefiles.

      The default value is `single`.

      The supported values are:

      * single
      * table\_per\_file
    </ParamField>

    <ParamField body="text_comment_string">
      Specifies the character string that should be interpreted as a comment line prefix in the source data.  All lines in the data starting with the provided string are ignored.

      For *delimited\_text* *file\_type* only.

      The default value is `#`.
    </ParamField>

    <ParamField body="text_delimiter">
      Specifies the character delimiting field values in the source data and field names in the header (if present).

      For *delimited\_text* *file\_type* only.

      The default value is `,`.
    </ParamField>

    <ParamField body="text_escape_character">
      Specifies the character that is used to escape other characters in the source data.

      An 'a', 'b', 'f', 'n', 'r', 't', or 'v' preceded by an escape character will be interpreted as the ASCII bell, backspace, form feed, line feed, carriage return, horizontal tab, and vertical tab, respectively.  For example, the escape character followed by an 'n' will be interpreted as a newline within a field value.

      The escape character can also be used to escape the quoting character, and will be treated as an escape character whether it is within a quoted field value or not.

      For *delimited\_text* *file\_type* only.
    </ParamField>

    <ParamField body="text_has_header">
      Indicates whether the source data contains a header row.

      For *delimited\_text* *file\_type* only.

      The default value is `true`.

      The supported values are:

      * true
      * false
    </ParamField>

    <ParamField body="text_header_property_delimiter">
      Specifies the delimiter for [column properties](../../concepts/types/#column-properties) in the header row (if present).  Cannot be set to same value as *text\_delimiter*.

      For *delimited\_text* *file\_type* only.

      The default value is `|`.
    </ParamField>

    <ParamField body="text_null_string">
      Specifies the character string that should be interpreted as a null value in the source data.

      For *delimited\_text* *file\_type* only.

      The default value is `\N`.
    </ParamField>

    <ParamField body="text_quote_character">
      Specifies the character that should be interpreted as a field value quoting character in the source data.  The character must appear at beginning and end of field value to take effect. Delimiters within quoted fields are treated as literals and not delimiters. Within a quoted field, two consecutive quote characters will be interpreted as a single literal quote character, effectively escaping it.  To not have a quote character, specify an empty string.

      For *delimited\_text* *file\_type* only.

      The default value is `"`.
    </ParamField>

    <ParamField body="text_search_columns">
      Add 'text\_search' property to internally inferenced string columns. Comma separated list of column names or '\*' for all columns. To add text\_search property only to string columns of minimum size, set also the option 'text\_search\_min\_column\_length'.
    </ParamField>

    <ParamField body="text_search_min_column_length">
      Set minimum column size. Used only when 'text\_search\_columns' has a value.
    </ParamField>

    <ParamField body="transformations">
      Comma-separated expressions, one per target table column.  Each expression is evaluated per record.  Empty entries (two consecutive commas) mean no transformation for that column -- the value is resolved from the input record, table default, NULL, or an error. Expressions may reference input columns by name or by position ($1 for the first input column, $2 for the second, etc.).

      The default value is ''.
    </ParamField>

    <ParamField body="trim_space">
      If set to *true*, remove leading or trailing space from fields.

      The default value is `false`.

      The supported values are:

      * true
      * false
    </ParamField>

    <ParamField body="truncate_strings">
      If set to *true*, truncate string values that are longer than the column's type size.

      The default value is `false`.

      The supported values are:

      * true
      * false
    </ParamField>

    <ParamField body="truncate_table">
      If set to *true*, truncates the table specified by input parameter *table\_name* prior to loading the file(s).

      The default value is `false`.

      The supported values are:

      * true
      * false
    </ParamField>

    <ParamField body="type_inference_max_records_read">
      The default value is ''.
    </ParamField>

    <ParamField body="type_inference_mode">
      Optimize type inference mode.

      The default value is `accuracy`.

      * **accuracy**: Scans data to get exactly-typed and sized columns for all data scanned.
      * **speed**: Scans data and picks the widest possible column types so that 'all' values will fit with minimum data scanned.
    </ParamField>

    <ParamField body="update_on_existing_pk">
      Specifies the record collision policy for inserting into a table with a [primary key](../../concepts/tables/#primary-keys). If set to *true*, any existing table record with primary key values that match those of a record being inserted will be replaced by that new record (the new data will be "upserted"). If set to *false*, any existing table record with primary key values that match those of a record being inserted will remain unchanged, while the new record will be rejected and the error handled as determined by *ignore\_existing\_pk* and *error\_handling*.  If the specified table does not have a primary key, then this option has no effect.

      The default value is `false`.

      * **true**: Upsert new records when primary keys match existing records.
      * **false**: Reject new records when primary keys match existing records.
    </ParamField>
  </Expandable>
</ParamField>

## Output Parameter Description

The Kinetica server embeds the endpoint response inside a standard response structure which contains status information and the actual response to the query.  Here is a description of the various fields of the wrapper:

<ResponseField name="status" type="String">
  'OK' or 'ERROR'
</ResponseField>

<ResponseField name="message" type="String">
  Empty if success or an error message
</ResponseField>

<ResponseField name="data_type" type="String">
  'insert\_records\_from\_payload\_response' or 'none' in case of an error
</ResponseField>

<ResponseField name="data" type="String">
  Empty string
</ResponseField>

<ResponseField name="data_str" type="JSON or String">
  This embedded JSON represents the result of the /insert/records/frompayload endpoint:

  <Expandable title="data_str">
    <ResponseField name="table_name" type="string">
      Value of input parameter *table\_name*.
    </ResponseField>

    <ResponseField name="type_id" type="string">
      ID of the currently registered table structure [type](../../concepts/types/) for the target table.
    </ResponseField>

    <ResponseField name="type_definition" type="string">
      A JSON string describing the columns of the target table.
    </ResponseField>

    <ResponseField name="type_label" type="string">
      The user-defined description associated with the target table's structure.
    </ResponseField>

    <ResponseField name="type_properties" type="map of string to arrays of strings">
      A mapping of each target table column name to an array of column properties associated with that column.
    </ResponseField>

    <ResponseField name="count_inserted" type="long">
      Number of records inserted into the target table.
    </ResponseField>

    <ResponseField name="count_skipped" type="long">
      Number of records skipped, when not running in *abort* error handling mode.
    </ResponseField>

    <ResponseField name="count_updated" type="long">
      \[Not yet implemented]  Number of records updated within the target table.
    </ResponseField>

    <ResponseField name="info" type="map of string to strings">
      Additional information.
    </ResponseField>
  </Expandable>

  Empty string in case of an error.
</ResponseField>


This documentation is built and hosted on [Mintlify](https://mintlify.com), a developer documentation platform.